Показать сообщение отдельно
Старый 01-03-2011, 06:06   #17
 
Аватар для ErikPshat
 
Откуда: Москва
Сообщений: 656
Репутация: 1098
PSP-1000 [5.00 M33-6]

Лучший Мозг 

По умолчанию

Yoti, ё-моё. Всё, нашёл ошибку.
Спойлер: offtop:

Почему-то в systemctrl.h в линии 200 стояло
Код:
typedef int (* STMOD_HANDLER)(SceModule2 *);
Проверил в main.c, так там идёт код SceModule, т.е. без 2.
Удалил 2-ку и всё сразу побежало )))

Только в конце ещё ошибку выдало
Код:
psp-packer downgrade_ctrl.prx / FAILED
Ну я понял, что не хватает psp-packer.exe в корневой папке bin.
Он лежал закопанный в pspsdk\psp\sdk\psp-packer\psp-packer.exe

Я его переложил в BIN, но блин ошибка осталась. Потом решил вручную проверить, кинул тупо downgrade_ctrl.prx на psp-packer.exe, вот тут выползло, типа отсутствует файл cygz.dll. Ну я его выловил из Тотал Коммандера и кинул в System32 )))

Короче, всё зашибись, одной головной болью меньше. Просто пишу тебе, чтобы у тебя таких граблей не случилось, если чё.

А это, даунгрейдер не работает вроде на 6.36, а на 6.37 и подавно, потому что ключи декриптовки он не добавил в pspdecrypt.c. Только видать пару ключей нашёл от 6.36, а надо 6 штук.

ErikPshat добавил 01-03-2011 в 03:06
Ах да, Дейви использует HBL Sukkiri. И что за демка такая Sukkiri? Откуда она взялась? Я думал это какая-то новая игра, требующая прошивку 6.31 и выше. А оказывается она использует ключ 0хADF305F0, который присутствует в прошивках от 3.02 и выше ))) На более ранних даже не стал проверять.
То есть, если подписывать этим ключём все хомки, то они будут работать на всех оффпрошивках. Впрочем PrxEncrypter так-же использует этот ключ, только размер файла у него 5М.

Последний раз редактировалось ErikPshat; 01-03-2011 в 08:37. Причина: Добавлено сообщение
ErikPshat вне форума   Ответить с цитированием